Start a new topic

LaMetic clock displays 'clock symbol' - FEL - 'PC monitor'

My LaMetic clock displays 'clock symbol' - FEL - 'PC monitor' and nothing else. Attempting to reset it did not prevent this form happening. Please help!


5 people have this problem

Yes that’s what happened

ok so it automatically started updating once connected to the PC ?

I was not able to enter in the recovery mode so I tried my last chance and connecting it to my PC and as soon as I connected it it started to update.

Thanks for the reply, did the "clock" - Fel - "Computer" on the display  disappear when you connected to the PC, or were you able to start the "recovery" mode ? ("Volume-UP" + action button on top )

I took the USB cable from the power supply connected it to a Windows PC and it started to do an update. The I waited until it finished and suddenly the time was displayed again. That’s all. Hope you will also find a solution for your device

What more specifically did you do, what steps ? and did you use a Windows PC/Mac or Linux ?

any help or guidance would be greatly appreciated.

I found a solution. Connecting the LaMetric to my PC resolved the problem.
Same problem here. Tried the fix posted above but no chance

I have the same issue, the solution provided above makes no change, any suggestions ?

Dear Patrick,


Thank you for your feedback. 


Recently we published article solution to case when 'FEL' appears - https://help.lametric.com/support/solutions/articles/6000257445-lametric-device-displays-fel-. Other troubleshootings we posted you can find here - https://help.lametric.com/support/solutions.


If you have any other questions write back us anytime or contact directly support@lametric.com.

It would be better if solutions to problems like this were posted here or in an FAQ page, as opposed to only giving them out via e-mail.

Hi Peter!


Could you please drop an email on support@lametric.com with the issue? We'll send you further solutions on this.


Thanks in advance.

Login or Signup to post a comment