Start a new topic

Radio App & Stations

 Need a way to add stations that are not listed in the app's offerings.  Would like to add local stations.

5 people like this idea

additionaly it'd be great to just show the text messages broadcastet and not showing the waveforms of the music. Could be selectable in the app.



Great news. We have released LaMetric Time app update with the ability to add custom radio stations. It is available starting from version 1.4.x. Just go to Radio app preferences, choose "Radio Stations" and add a new one. Notice "+" action at the top of the dialog. It allows entering custom URL of your favorite local radio station. We support major stream formats as well as M3U playlists.

Please note that iOS app is not available yet. Currently, Apple is reviewing it. We hope the app will be available for download less than in a week.

Your feedback is appreciated.


Great feature, but sadly your implementation does not work with redirects. See Swissgroove for example:

Here you are only provided with a php-file ( which returns a M3U-Playlist. But Lametric does not play the station. Of course: If you host the m3u-file by yourself, accessable with a direkt m3u-Link there is no problem. But it would be nice if i could just point to the official php-site. 

I have the same problem I live in Australia and according to the ABC website here, the following is a direct stream URL but it does not work on LaMetric, does anyone know why?


Neither one works and when they are the only 2 radio stations installed I get a big white arrow pointing to 0 on the actual LaMetric.

Any help would be appreciated.

Those are ".pls" URLs not an mp3 link.  They are designed to be used for iTunes.  Try  this instead:


They don't open up iTunes, just a blank website with the ability to play. According to their website the 1st is MP3 and the 2nd is AAC+. 

I tried your link, I got better than the arrow & 0 but it went to flat line, no sound.

Hmmm ....  I tried that link I sent you on my LaMetric and it worked fine.  I am using the iOS app.  Not sure if that makes a difference.  You might try verifying my link via a separate player like VLC.  I just did and it's OK.  Wish I could be more help.


Hi Greg, not sure what I did wrong but it is working now. I trashed the station, did the firmware update and retyped the station info and it's working.

Thanks for your time Greg.

Login or Signup to post a comment