Start a new topic

clock face icon not changing


I try to change the clock icon. I post the following data:

{"id":"clock.clockface","params": {"icon": 72}}


And I receive the following response: { "success" : { "data" : {  }, "path" : "/api/v2/device/apps/com.lametric.clock/widgets/08b8eac21074f8f7e5a29f2855ba8060/actions" } }

So for me everything looks ok, but the icon is not changing. What may be wrong?

best regards,


As I was digging this API endpoint too, I realised that the only way to change the clockface icon is with an icon parameter consisting of a base64 data string of the icon.
Referencing the icon with its id (adding a 'a' or 'i' regarding if animated or not) doesn't work.

I don't understand why they didn't implement that and will submit this as a feature request


I forgot to thank you Victor: Thank you!

This tipp has worked. But the issue now is, if I update the clock face there is a big chance the clock "freezes". This means autoscroll is deactivated. I solved this issue with calling the "switch to next app" endpoint after changing the clock face. This workaround has worked until the last update of the Lametric. Now the clock deactivated autoscroll also if you call the "switch to next app". And it also deactivated autoscroll if I change the clock face. And there is no endpoint to re-activate auto-scroll or have I missed it?

best regards


Login or Signup to post a comment